System Requirements

Security-Related Airspace Course

MINIMUM System Requirements for Security-Related Airspace Course
Browsers
Internet Explorerversion 9 or Higher
Google Chromeversion 21 or Higher
Mozilla Firefoxversion 15 or Higher
Apple Safariversion 5.1 or Higher
Software
Adobe Flash PlayerVersion 10.3 or Higher Download Here
Adobe ReaderVersion 9 or Higher Download Here
Click here to check your Browser Settings